ansible: ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x bef...
CVE-2019-10206 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1+esm5 (version 2.5.1+dfsg-1ubuntu0.1+esm5), released May 27, 2021. It is not reported as exploited. Patch Radar priority: Routine.
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| ansible · Ubuntu 18.04.6 LTS (bionic) | 2.5.1+dfsg-1ubuntu0.1+esm5 | ansible 2.5.1+dfsg-1ubuntu0.1+esm5 | May 27, 2021 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.