# CVE-2019-10206: ansible: ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x bef...

CVE-2019-10206 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1+esm5 (version 2.5.1+dfsg-1ubuntu0.1+esm5), released May 27, 2021. It is not reported as exploited. Patch Radar priority: Routine.

- Web page: https://patchblox.com/security/cve/CVE-2019-10206
- Priority: Routine
- CVSS: n/a (Medium)
- EPSS: 0.0150
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Nov 22, 2019

## Description

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | ansible Ubuntu 18.04.6 LTS (bionic) | 2.5.1+dfsg-1ubuntu0.1+esm5 | [ansible 2.5.1+dfsg-1ubuntu0.1+esm5](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-ansible-2.5.1-dfsg-1ubuntu0.1-esm5.md) | May 27, 2021 |

---

Data as of 2026-11-08T00:53:09Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
