CVE-2024-23635

libowasp-antisamy-java: AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources

CVE-2024-23635 is fixed in libowasp-antisamy-java on 1 platform by DEBIAN-CVE-2024-23635 (version 1.7.8-1), released February 2, 2024. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
6.1
medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0037
30th percentile

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.

Where it's fixed

ProductFixed inFixReleased
Linux
libowasp-antisamy-java · Debian 14 1.7.8-1 DEBIAN-CVE-2024-23635 Feb 2, 2024

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.