{
  "cveId": "CVE-2024-23635",
  "url": "https://patchblox.com/security/cve/CVE-2024-23635",
  "summary": "CVE-2024-23635 is fixed in libowasp-antisamy-java on 1 platform by DEBIAN-CVE-2024-23635 (version 1.7.8-1), released February 2, 2024. It is not reported as exploited. Patch Radar priority: Routine.",
  "title": "libowasp-antisamy-java: AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources",
  "description": "AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the \u0060preserveComments\u0060 directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy\u0027s sanitized output. Patched in AntiSamy 1.7.5 and later.",
  "published": "2024-02-02T17:15:11Z",
  "severity": "medium",
  "cvss": 6.1,
  "cvssVector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N",
  "epss": 0.00368,
  "epssPercentile": 0.30831,
  "priority": "Routine",
  "priorityTier": 4,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "libowasp-antisamy-java",
      "release": "Debian 14",
      "fixedVersion": "1.7.8-1",
      "fix": "DEBIAN-CVE-2024-23635",
      "url": "https://patchblox.com/security/fix/linux/debian-cve-2024-23635",
      "released": "2024-02-02T17:15:11Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T06:59:42Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}