libssl3t64: The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly usesthe AAD data as the MAC key
CVE-2022-1434 is fixed in 9 products on 1 platform, first by libssl3 3.0.2-0ubuntu1.1, released May 2, 2022. It is not reported as exploited. Patch Radar priority: Routine.
The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly usesthe AAD data as the MAC key. This makes the MAC key trivially predictable.An attacker could exploit this issue by performing a man-in-the-middleattack to modify data being sent from one endpoint to an OpenSSL 3.0recipient such that the modified data would still pass the MAC integritycheck. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL3.0 endpoint will always be rejected by the recipient and the connectionwill fail at that point. Many application protocols require data to be sentfrom the client to the server first. Therefore, in such a case, only anOpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0client. If both endpoints are OpenSSL 3.0 then the attacker could modifydata being sent in both directions. In this case both clients and serverscould be affected, regardless of the application protocol. Note that in theabsence of an attacker this bug means that an OpenSSL 3.0 endpointcommunicating with a non-OpenSSL 3.0 endpoint will fail to complete thehandshake when using this ciphersuite. The confidentiality of data is notimpacted by this issue, i.e. an attacker cannot decrypt data that has beenencrypted using this ciphersuite - they can only modify it. In order forthis attack to work both endpoints must legitimately negotiate the RC4-MD5ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0,and is not available within the default provider or the default ciphersuitelist. This ciphersuite will never be used if TLSv1.3 has been negotiated.In order for an OpenSSL 3.0 endpoint to use this ciphersuite the followingmust have occurred: 1) OpenSSL must have been compiled with the(non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL musthave had the legacy provider explicitly loaded (either through applicationcode or via configuration) 3) The ciphersuite must have been explicitlyadded to the ciphersuite list 4) The libssl security level must have beenset to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must havebeen negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite inpreference to any others that both endpoints have in common Fixed inOpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| libssl3 · Ubuntu 22.04.1 LTS (jammy) | 3.0.2-0ubuntu1.1 | libssl3 3.0.2-0ubuntu1.1 | May 2, 2022 |
| libssl3t64 · Ubuntu 24.10 (oracular) | 3.0.2-0ubuntu2 | libssl3t64 3.0.2-0ubuntu2 | May 3, 2022 |
| libssl3t64 · Ubuntu 25.04 (plucky) | 3.0.2-0ubuntu2 | libssl3t64 3.0.2-0ubuntu2 | May 3, 2022 |
| openssl · Ubuntu 22.04.1 LTS (jammy) | 3.0.2-0ubuntu1.1 | openssl 3.0.2-0ubuntu1.1 | May 2, 2022 |
| openssl · Ubuntu 24.10 (oracular) | 3.0.2-0ubuntu2 | openssl 3.0.2-0ubuntu2 | May 3, 2022 |
| openssl · Ubuntu 25.04 (plucky) | 3.0.2-0ubuntu2 | openssl 3.0.2-0ubuntu2 | May 3, 2022 |
| openssl · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-debuginfo · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-debugsource · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-devel · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-libs · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-libs-debuginfo · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
| openssl-perl · amzn 2023 | 1:3.0.5-1.amzn2023.0.4 | ALAS2023-2023-051 | Feb 17, 2023 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.