{
  "cveId": "CVE-2022-1434",
  "url": "https://patchblox.com/security/cve/CVE-2022-1434",
  "summary": "CVE-2022-1434 is fixed in 9 products on 1 platform, first by libssl3 3.0.2-0ubuntu1.1, released May 2, 2022. It is not reported as exploited. Patch Radar priority: Routine.",
  "title": "libssl3t64: The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly usesthe AAD data as the MAC key",
  "description": "The OpenSSL 3.0 implementation of the RC4-MD5 ciphersuite incorrectly usesthe AAD data as the MAC key. This makes the MAC key trivially predictable.An attacker could exploit this issue by performing a man-in-the-middleattack to modify data being sent from one endpoint to an OpenSSL 3.0recipient such that the modified data would still pass the MAC integritycheck. Note that data sent from an OpenSSL 3.0 endpoint to a non-OpenSSL3.0 endpoint will always be rejected by the recipient and the connectionwill fail at that point. Many application protocols require data to be sentfrom the client to the server first. Therefore, in such a case, only anOpenSSL 3.0 server would be impacted when talking to a non-OpenSSL 3.0client. If both endpoints are OpenSSL 3.0 then the attacker could modifydata being sent in both directions. In this case both clients and serverscould be affected, regardless of the application protocol. Note that in theabsence of an attacker this bug means that an OpenSSL 3.0 endpointcommunicating with a non-OpenSSL 3.0 endpoint will fail to complete thehandshake when using this ciphersuite. The confidentiality of data is notimpacted by this issue, i.e. an attacker cannot decrypt data that has beenencrypted using this ciphersuite - they can only modify it. In order forthis attack to work both endpoints must legitimately negotiate the RC4-MD5ciphersuite. This ciphersuite is not compiled by default in OpenSSL 3.0,and is not available within the default provider or the default ciphersuitelist. This ciphersuite will never be used if TLSv1.3 has been negotiated.In order for an OpenSSL 3.0 endpoint to use this ciphersuite the followingmust have occurred: 1) OpenSSL must have been compiled with the(non-default) compile time option enable-weak-ssl-ciphers 2) OpenSSL musthave had the legacy provider explicitly loaded (either through applicationcode or via configuration) 3) The ciphersuite must have been explicitlyadded to the ciphersuite list 4) The libssl security level must have beenset to 0 (default is 1) 5) A version of SSL/TLS below TLSv1.3 must havebeen negotiated 6) Both endpoints must negotiate the RC4-MD5 ciphersuite inpreference to any others that both endpoints have in common Fixed inOpenSSL 3.0.3 (Affected 3.0.0,3.0.1,3.0.2).",
  "published": "2022-05-02T17:00:00Z",
  "severity": "Low",
  "epss": 0.01228,
  "epssPercentile": 0.69059,
  "priority": "Routine",
  "priorityTier": 4,
  "exploited": false,
  "vendorExploited": false,
  "disclosed": false,
  "fixes": [
    {
      "platform": "linux",
      "product": "libssl3",
      "release": "Ubuntu 22.04.1 LTS (jammy)",
      "fixedVersion": "3.0.2-0ubuntu1.1",
      "fix": "libssl3 3.0.2-0ubuntu1.1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-jammy-libssl3-3.0.2-0ubuntu1.1",
      "released": "2022-05-02T17:00:00Z"
    },
    {
      "platform": "linux",
      "product": "libssl3t64",
      "release": "Ubuntu 24.10 (oracular)",
      "fixedVersion": "3.0.2-0ubuntu2",
      "fix": "libssl3t64 3.0.2-0ubuntu2",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-oracular-libssl3t64-3.0.2-0ubuntu2",
      "released": "2022-05-03T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "libssl3t64",
      "release": "Ubuntu 25.04 (plucky)",
      "fixedVersion": "3.0.2-0ubuntu2",
      "fix": "libssl3t64 3.0.2-0ubuntu2",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-plucky-libssl3t64-3.0.2-0ubuntu2",
      "released": "2022-05-03T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl",
      "release": "Ubuntu 22.04.1 LTS (jammy)",
      "fixedVersion": "3.0.2-0ubuntu1.1",
      "fix": "openssl 3.0.2-0ubuntu1.1",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-jammy-openssl-3.0.2-0ubuntu1.1",
      "released": "2022-05-02T17:00:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl",
      "release": "Ubuntu 24.10 (oracular)",
      "fixedVersion": "3.0.2-0ubuntu2",
      "fix": "openssl 3.0.2-0ubuntu2",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-oracular-openssl-3.0.2-0ubuntu2",
      "released": "2022-05-03T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl",
      "release": "Ubuntu 25.04 (plucky)",
      "fixedVersion": "3.0.2-0ubuntu2",
      "fix": "openssl 3.0.2-0ubuntu2",
      "url": "https://patchblox.com/security/fix/linux/ubuntu-plucky-openssl-3.0.2-0ubuntu2",
      "released": "2022-05-03T00:00:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-debuginfo",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-debugsource",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-devel",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-libs",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-libs-debuginfo",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    },
    {
      "platform": "linux",
      "product": "openssl-perl",
      "release": "amzn 2023",
      "fixedVersion": "1:3.0.5-1.amzn2023.0.4",
      "fix": "ALAS2023-2023-051",
      "url": "https://patchblox.com/security/fix/linux/alas2023-2023-051",
      "released": "2023-02-17T20:45:00Z"
    }
  ],
  "noFixYet": [],
  "dataAsOf": "2026-11-08T06:59:42Z",
  "attribution": {
    "text": "Data: Patchblox Patch Radar",
    "url": "https://patchblox.com/security/patch-radar",
    "terms": "https://patchblox.com/security/patch-radar/use-the-data"
  }
}