CVE-2021-36367

PuTTY: Insufficient Verification of Data Authenticity

CVE-2021-36367 is fixed in PuTTY on 1 platform by PuTTY 0.76.0.0 (version 0.76.0.0), released July 17, 2021. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
8.1
No vendor severity
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0111
66th percentile

PuTTY through 0.75 proceeds with establishing an SSH session even if it has never sent a substantive authentication response. This makes it easier for an attacker-controlled SSH server to present a later spoofed authentication prompt (that the attacker can use to capture credential data, and use that data for purposes that are undesired by the client user).

Where it's fixed

ProductFixed inFixReleased
Windows apps
PuTTY 0.76.0.0 PuTTY 0.76.0.0 Jul 17, 2021

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.