# CVE-2021-36367: PuTTY: Insufficient Verification of Data Authenticity

CVE-2021-36367 is fixed in PuTTY on 1 platform by PuTTY 0.76.0.0 (version 0.76.0.0), released July 17, 2021. It is not reported as exploited. Patch Radar priority: High.

- Web page: https://patchblox.com/security/cve/CVE-2021-36367
- Priority: High
- CVSS: 8.1
- EPSS: 0.0111
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Jul 9, 2021
- Weakness: CWE-345: Insufficient Verification of Data Authenticity
- Vendor advisory: https://nvd.nist.gov/vuln/detail/CVE-2021-36367

## Description

PuTTY through 0.75 proceeds with establishing an SSH session even if it has never sent a substantive authentication response. This makes it easier for an attacker-controlled SSH server to present a later spoofed authentication prompt (that the attacker can use to capture credential data, and use that data for purposes that are undesired by the client user).

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Windows apps | PuTTY | 0.76.0.0 | [PuTTY 0.76.0.0](https://patchblox.com/security/data/fix/windows-app/putty.putty-0.76.0.0.md) | Jul 17, 2021 |

---

Data as of 2026-11-08T00:53:09Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
