CVE-2018-1160

netatalk: Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c

CVE-2018-1160 is fixed in netatalk on 1 platform by netatalk 2.2.6-1ubuntu0.18.04.2 (version 2.2.6-1ubuntu0.18.04.2), released December 20, 2018. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.8642
99th percentile

Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.

Where it's fixed

ProductFixed inFixReleased
Linux
netatalk · Ubuntu 18.04.6 LTS (bionic) 2.2.6-1ubuntu0.18.04.2 netatalk 2.2.6-1ubuntu0.18.04.2 Dec 20, 2018