# CVE-2018-1160: netatalk: Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c

CVE-2018-1160 is fixed in netatalk on 1 platform by netatalk 2.2.6-1ubuntu0.18.04.2 (version 2.2.6-1ubuntu0.18.04.2), released December 20, 2018. It is not reported as exploited. Patch Radar priority: Routine.

- Web page: https://patchblox.com/security/cve/CVE-2018-1160
- Priority: Routine
- CVSS: n/a (Medium)
- EPSS: 0.8642
- CISA KEV: not listed
- Exploited (vendor report): no
- Publicly disclosed: no
- Published: Dec 20, 2018

## Description

Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.

## Where it's fixed

| Platform | Product | Fixed in | Fix | Released |
|---|---|---|---|---|
| Linux | netatalk Ubuntu 18.04.6 LTS (bionic) | 2.2.6-1ubuntu0.18.04.2 | [netatalk 2.2.6-1ubuntu0.18.04.2](https://patchblox.com/security/data/fix/linux/ubuntu-bionic-netatalk-2.2.6-1ubuntu0.18.04.2.md) | Dec 20, 2018 |

---

Data as of 2026-11-07T18:46:35Z UTC. Source: Patchblox Patch Radar (https://patchblox.com/security/patch-radar). Patchblox finds out-of-date software on Windows, macOS and Linux and updates it through release rings: https://patchblox.com/demo

Free to use with attribution: show "Data: Patchblox Patch Radar" with a link to https://patchblox.com/security/patch-radar. Terms, including what needs a written agreement: https://patchblox.com/security/patch-radar/use-the-data

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.
