CVE-2026-9358

node-css-loader: A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2

CVE-2026-9358 is fixed in node-css-loader on 1 platform by DEBIAN-CVE-2026-9358 (version 6.8.1+~cs14.1.4-1), released May 24, 2026. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
No vendor severity
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0033
25th percentile

A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.

Where it's fixed

ProductFixed inFixReleased
Linux
node-css-loader · Debian 14 6.8.1+~cs14.1.4-1 DEBIAN-CVE-2026-9358 May 24, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.