CVE-2026-73258

mongoose: Mongoose is an embedded web server and network library

CVE-2026-73258 is fixed in mongoose on 1 platform by DEBIAN-CVE-2026-73258 (version 7.22+ds-1), released August 21, 2026. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
6.5
medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0046
40th percentile

Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.

Where it's fixed

ProductFixed inFixReleased
Linux
mongoose · Debian 14 7.22+ds-1 DEBIAN-CVE-2026-73258 Aug 21, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.