simplesamlphp: SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability
CVE-2026-49284 is fixed in simplesamlphp on 1 platform by DEBIAN-CVE-2026-49284 (version 2.4.8-1), released July 17, 2026. It is not reported as exploited. Patch Radar priority: High.
SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prior to 2.4.7 and 2.5.2, SimpleSAMLphp's SAML SP ACS path does not enforce the IdP selected for an SP-initiated login when unsigned Response/InResponseTo is combined with a signed assertion lacking SubjectConfirmationData/InResponseTo, allowing a response issued by one trusted IdP to be bound to SP state created for another IdP and bypass flows that route users to a specific IdP, including deployments that set enable_unsolicited to false. This issue is fixed in versions 2.4.7 and 2.5.2.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| simplesamlphp · Debian 14 | 2.4.8-1 | DEBIAN-CVE-2026-49284 | Jul 17, 2026 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.