CVE-2026-44728

node-babel7: Babel is a compiler for writing next generation JavaScript

CVE-2026-44728 is fixed in node-babel7 on 1 platform by DEBIAN-CVE-2026-44728 (version 8.0.4+ds1+~cs177.303.116-2), released May 26, 2026. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.8
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0013
2nd percentile

Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.

Where it's fixed

ProductFixed inFixReleased
Linux
node-babel7 · Debian 14 8.0.4+ds1+~cs177.303.116-2 DEBIAN-CVE-2026-44728 May 26, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.