CVE-2026-4428

amazon-efs-utils: Package updates are available for Amazon Linux 2023 that fix the following vulnerabilities: CVE-2026-4428: A logic e...

CVE-2026-4428 is fixed in 5 products on 1 platform, first by ALAS2023-2026-1564, released April 13, 2026. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
n/a
important
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0026
17th percentile

Package updates are available for Amazon Linux 2023 that fix the following vulnerabilities: CVE-2026-4428: A logic error in CRL distribution point validation in AWS-LC before 1.71.0 causes partitioned CRLs to be incorrectly rejected as out of scope, which allows a revoked certificate to bypass certificate revocation checks. To remediate this issue, users should upgrade to AWS-LC 1.71.0 or AWS-LC-FIPS-3.3.0. CVE-2026-3338: Improper signature validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass signature verification when processing PKCS7 objects with Authenticated Attributes. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0. CVE-2026-3337: Observable timing discrepancy in AES-CCM decryption in AWS-LC allows an unauthenticated user to potentially determine authentication tag validity via timing analysis. The impacted implementations are through the EVP CIPHER API: EVP_aes_128_ccm, EVP_aes_192_ccm, and EVP_aes_256_ccm. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0. CVE-2026-3336: Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0. CVE-2026-25727: time provides date and time handling in Rust. From 0.3.6 to before 0.3.47, when user-provided input is provided to any type that parses with the RFC 2822 format, a denial of service attack via stack exhaustion is possible. The attack relies on formally deprecated and rarely-used features that are part of the RFC 2822 format used in a malicious manner. Ordinary, non-malicious input will never encounter this scenario. A limit to the depth of recursion was added in v0.3.47. From this version, an error will be returned rather than exhausting the stack.

Where it's fixed

ProductFixed inFixReleased
Linux
amazon-efs-utils · amzn 2023 3.0.0-4.amzn2023 ALAS2023-2026-1564 Apr 13, 2026
aws-nitro-tpm-tools · amzn 2023 1.1.2-1.amzn2023 ALAS2023-2026-1905 Jul 6, 2026
mount-s3 · amzn 2023 1.22.3-1.amzn2023 ALAS2023-2026-1655 May 11, 2026
mount-s3-debuginfo · amzn 2023 1.22.3-1.amzn2023 ALAS2023-2026-1655 May 11, 2026
mount-s3-debugsource · amzn 2023 1.22.3-1.amzn2023 ALAS2023-2026-1655 May 11, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.