CVE-2026-43870

Apache Thrift: Node.js web_server.js multi-vulnerability

CVE-2026-43870 is fixed in 2 products on 1 platform, first by DEBIAN-CVE-2026-43870, released May 27, 2026. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
8.6
Important
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0038
32nd percentile

Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

Where it's fixed

ProductFixed inFixReleased
Linux
opentelemetry-collector · RHEL 10 0.152.1-1.el10_0 RHSA-2026:53413 Jul 2, 2026
thrift · Debian 14 0.23.0-3 DEBIAN-CVE-2026-43870 May 27, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.