CVE-2026-42268

modsecurity: ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx

CVE-2026-42268 is fixed in modsecurity on 1 platform, first by DEBIAN-CVE-2026-42268, released May 15, 2026. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.5
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0040
33rd percentile

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

Where it's fixed

ProductFixed inFixReleased
Linux
modsecurity · Debian 12.15 (bookworm) 3.0.9-1+deb12u2 DEBIAN-CVE-2026-42268 May 15, 2026
modsecurity · Debian 13.5 (trixie) 3.0.14-1+deb13u1 DEBIAN-CVE-2026-42268 May 15, 2026
modsecurity · Debian 14 3.0.15-1 DEBIAN-CVE-2026-42268 May 15, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.