perl: Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulner...
CVE-2026-4176 is fixed in perl on 1 platform, first by DEBIAN-CVE-2026-4176, released March 29, 2026. It is not reported as exploited. Patch Radar priority: Urgent.
Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| perl · Debian 12.15 (bookworm) | 5.10.0-21 | DEBIAN-CVE-2026-4176 | Mar 29, 2026 |
| perl · Debian 13.5 (trixie) | 5.10.0-21 | DEBIAN-CVE-2026-4176 | Mar 29, 2026 |
| perl · Debian 14 | 5.10.0-21 | DEBIAN-CVE-2026-4176 | Mar 29, 2026 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.