CVE-2026-33019

libsixel: libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel

CVE-2026-33019 is fixed in libsixel on 1 platform by DEBIAN-CVE-2026-33019 (version 1:1.8.7-r2-1), released April 14, 2026. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.1
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0026
17th percentile

libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow leading to an out-of-bounds heap read in the --crop option handling of img2sixel, where positive coordinates up to INT_MAX are accepted without overflow-safe bounds checking. In sixel_encoder_do_clip(), the expression clip_w + clip_x overflows to a large negative value when clip_x is INT_MAX, causing the bounds guard to be skipped entirely, and the unclamped coordinate is passed through sixel_frame_clip() to clip(), which computes a source pointer far beyond the image buffer and passes it to memmove(). An attacker supplying a specially crafted crop argument with any valid image can trigger an out-of-bounds read in the heap, resulting in a reliable crash and potential information disclosure. This issue has been fixed in version 1.8.7-r1.

Where it's fixed

ProductFixed inFixReleased
Linux
libsixel · Debian 14 1:1.8.7-r2-1 DEBIAN-CVE-2026-33019 Apr 14, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.