CVE-2025-66040

spotipy: Spotipy is a Python library for the Spotify Web API

CVE-2025-66040 is fixed in spotipy on 1 platform by DEBIAN-CVE-2025-66040 (version 2.25.2-1), released November 27, 2025. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
3.6
low
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0017
5th percentile

Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.

Where it's fixed

ProductFixed inFixReleased
Linux
spotipy · Debian 14 2.25.2-1 DEBIAN-CVE-2025-66040 Nov 27, 2025

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.