poco: A vulnerability was found in poco up to 1.14.1
CVE-2025-6375 is fixed in poco on 1 platform, first by DEBIAN-CVE-2025-6375, released June 21, 2025. It is not reported as exploited. Patch Radar priority: Routine.
A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| poco · Debian 13.5 (trixie) | 1.13.0-6+deb13u1 | DEBIAN-CVE-2025-6375 | Jun 21, 2025 |
| poco · Debian 14 | 1.14.2-2 | DEBIAN-CVE-2025-6375 | Jun 21, 2025 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.