CVE-2025-59933

gir1.2-vips-8.0: libvips is a demand-driven, horizontally threaded image processing library

CVE-2025-59933 is fixed in 6 products on 1 platform, first by DEBIAN-CVE-2025-59933, released September 29, 2025. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.8
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0019
8th percentile

libvips is a demand-driven, horizontally threaded image processing library. For versions 8.17.1 and below, when libvips is compiled with support for PDF input via poppler, the pdfload operation is affected by a buffer read overflow when parsing the header of a crafted PDF with a page that defines a width but not a height. Those using libvips compiled without support for PDF input are unaffected as well as thosewith support for PDF input via PDFium. This issue is fixed in version 8.17.2. A workaround for those affected is to block the VipsForeignLoadPdf operation via vips_operation_block_set, which is available in most language bindings, or to set VIPS_BLOCK_UNTRUSTED environment variable at runtime, which will block all untrusted loaders including PDF input via poppler.

Where it's fixed

ProductFixed inFixReleased
Linux
gir1.2-vips-8.0 · Ubuntu 18.04.6 LTS (bionic) 8.4.5-1ubuntu0.1~esm2 gir1.2-vips-8.0 8.4.5-1ubuntu0.1~esm2 Aug 20, 2026
gir1.2-vips-8.0 · Ubuntu 20.04 LTS (focal) 8.9.1-2ubuntu0.1~esm2 gir1.2-vips-8.0 8.9.1-2ubuntu0.1~esm2 Aug 20, 2026
gir1.2-vips-8.0 · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm3 gir1.2-vips-8.0 8.12.1-1ubuntu0.1~esm3 Aug 20, 2026
gir1.2-vips-8.0 · Ubuntu 24.04.5 LTS (noble) 8.15.1-1.1ubuntu0.1~esm2 gir1.2-vips-8.0 8.15.1-1.1ubuntu0.1~esm2 Aug 20, 2026
libvips-tools · Ubuntu 18.04.6 LTS (bionic) 8.4.5-1ubuntu0.1~esm2 libvips-tools 8.4.5-1ubuntu0.1~esm2 Aug 20, 2026
libvips-tools · Ubuntu 20.04 LTS (focal) 8.9.1-2ubuntu0.1~esm2 libvips-tools 8.9.1-2ubuntu0.1~esm2 Aug 20, 2026
libvips-tools · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm3 libvips-tools 8.12.1-1ubuntu0.1~esm3 Aug 20, 2026
libvips-tools · Ubuntu 24.04.5 LTS (noble) 8.15.1-1.1ubuntu0.1~esm2 libvips-tools 8.15.1-1.1ubuntu0.1~esm2 Aug 20, 2026
libvips42 · Ubuntu 18.04.6 LTS (bionic) 8.4.5-1ubuntu0.1~esm2 libvips42 8.4.5-1ubuntu0.1~esm2 Aug 20, 2026
libvips42 · Ubuntu 20.04 LTS (focal) 8.9.1-2ubuntu0.1~esm2 libvips42 8.9.1-2ubuntu0.1~esm2 Aug 20, 2026
libvips42 · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm3 libvips42 8.12.1-1ubuntu0.1~esm3 Aug 20, 2026
libvips42t64 · Ubuntu 24.04.5 LTS (noble) 8.15.1-1.1ubuntu0.1~esm2 libvips42t64 8.15.1-1.1ubuntu0.1~esm2 Aug 20, 2026
python-vipscc · Ubuntu 18.04.6 LTS (bionic) 8.4.5-1ubuntu0.1~esm2 python-vipscc 8.4.5-1ubuntu0.1~esm2 Aug 20, 2026
vips · Debian 13.5 (trixie) 8.16.1-1+deb13u2 DEBIAN-CVE-2025-59933 Sep 29, 2025
vips · Debian 14 8.17.3-1 DEBIAN-CVE-2025-59933 Sep 29, 2025

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.