CVE-2025-53689

jackrabbit: Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of...

CVE-2025-53689 is fixed in jackrabbit on 1 platform, first by DEBIAN-CVE-2025-53689, released July 14, 2025. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
8.8
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0054
45th percentile

Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Where it's fixed

ProductFixed inFixReleased
Linux
jackrabbit · Debian 13.5 (trixie) 2.20.11-1.1 DEBIAN-CVE-2025-53689 Jul 14, 2025
jackrabbit · Debian 14 2.20.11-1.1 DEBIAN-CVE-2025-53689 Jul 14, 2025

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.