CVE-2025-47291

containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.

CVE-2025-47291 is fixed in containerd on 1 platform by containerd 2.0.5-0ubuntu1 (version 2.0.5-0ubuntu1), released May 21, 2025. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.5
Moderate
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0029
21st percentile

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

Where it's fixed

ProductFixed inFixReleased
Linux
containerd · Ubuntu 25.10 (questing) 2.0.5-0ubuntu1 containerd 2.0.5-0ubuntu1 May 21, 2025

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.