CVE-2025-23217

mitmproxy: mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mi...

CVE-2025-23217 is fixed in mitmproxy on 1 platform by DEBIAN-CVE-2025-23217 (version 8.1.1-4), released February 6, 2025. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
No vendor severity
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0087
59th percentile

mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Where it's fixed

ProductFixed inFixReleased
Linux
mitmproxy · Debian 14 8.1.1-4 DEBIAN-CVE-2025-23217 Feb 6, 2025

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.