CVE-2024-8926

php8.2: In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using a certain non-standard conf...

CVE-2024-8926 is fixed in php8.2 on 1 platform by DEBIAN-CVE-2024-8926 (version 8.2.24-1~deb12u1), released October 8, 2024. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
8.8
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0366
89th percentile

In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using a certain non-standard configurations of Windows codepages, the fixes for  CVE-2024-4577 https://github.com/advisories/GHSA-vxpp-6299-mxw3  may still be bypassed and the same command injection related to Windows "Best Fit" codepage behavior can be achieved. This may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.

Where it's fixed

ProductFixed inFixReleased
Linux
php8.2 · Debian 12.15 (bookworm) 8.2.24-1~deb12u1 DEBIAN-CVE-2024-8926 Oct 8, 2024

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.