spip: SPIP before 4.3.2, 4.2.16, and4.1.18 is vulnerable to a command injection issue
CVE-2024-8517 is fixed in spip on 1 platform, first by spip 3.1.4-4~deb9u5ubuntu0.1~esm2, released September 6, 2024. It is not reported as exploited. Patch Radar priority: High.
SPIP before 4.3.2, 4.2.16, and4.1.18 is vulnerable to a command injection issue. Aremote and unauthenticated attacker can execute arbitrary operating systemcommands by sending a crafted multipart file upload HTTP request.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| spip · Debian 13.5 (trixie) | 4.3.2+dfsg-1 | DEBIAN-CVE-2024-8517 | Sep 6, 2024 |
| spip · Debian 14 | 4.3.2+dfsg-1 | DEBIAN-CVE-2024-8517 | Sep 6, 2024 |
| spip · Ubuntu 18.04.6 LTS (bionic) | 3.1.4-4~deb9u5ubuntu0.1~esm2 | spip 3.1.4-4~deb9u5ubuntu0.1~esm2 | Sep 6, 2024 |
| spip · Ubuntu 20.04 LTS (focal) | 3.2.7-1ubuntu0.1+esm2 | spip 3.2.7-1ubuntu0.1+esm2 | Sep 6, 2024 |
| spip · Ubuntu 24.10 (oracular) | 4.3.1+dfsg-1ubuntu0.1 | spip 4.3.1+dfsg-1ubuntu0.1 | Jan 16, 2026 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.