ffmpeg: A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5
CVE-2024-7272 is fixed in ffmpeg on 1 platform, first by DEBIAN-CVE-2024-7272, released August 12, 2024. It is not reported as exploited. Patch Radar priority: High.
A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| ffmpeg · Debian 12.15 (bookworm) | 7:5.1.6-0+deb12u1 | DEBIAN-CVE-2024-7272 | Aug 12, 2024 |
| ffmpeg · Debian 13.5 (trixie) | 7:6.0-4 | DEBIAN-CVE-2024-7272 | Aug 12, 2024 |
| ffmpeg · Debian 14 | 7:6.0-4 | DEBIAN-CVE-2024-7272 | Aug 12, 2024 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.