CVE-2024-43700

xfpt: xfpt versions prior to 1.01 fails to handle appropriately some parametersinside the input data, resulting in a stack-...

CVE-2024-43700 is fixed in xfpt on 1 platform, first by xfpt 0.11-1ubuntu0.1, released August 29, 2024. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.8
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0026
17th percentile

xfpt versions prior to 1.01 fails to handle appropriately some parametersinside the input data, resulting in a stack-based buffer overflowvulnerability. When a user of the affected product is tricked to process aspecially crafted file, arbitrary code may be executed on the user'senvironment.

Where it's fixed

ProductFixed inFixReleased
Linux
xfpt · Debian 11.6 (bullseye) 0.11-1+deb11u1 DLA-3977-1 Nov 30, 2024
xfpt · Debian 12.15 (bookworm) 0.11-1+deb12u1 DEBIAN-CVE-2024-43700 Aug 29, 2024
xfpt · Debian 13.5 (trixie) 1.00-3 DEBIAN-CVE-2024-43700 Aug 29, 2024
xfpt · Debian 14 1.00-3 DEBIAN-CVE-2024-43700 Aug 29, 2024
xfpt · Ubuntu 22.04.1 LTS (jammy) 0.11-1ubuntu0.1 xfpt 0.11-1ubuntu0.1 Aug 29, 2024
xfpt · Ubuntu 24.04.5 LTS (noble) 1.00-2ubuntu0.24.04.1 xfpt 1.00-2ubuntu0.24.04.1 Aug 29, 2024
xfpt · Ubuntu 24.10 (oracular) 1.00-2ubuntu0.24.10.1 xfpt 1.00-2ubuntu0.24.10.1 Jan 16, 2026

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.