CVE-2024-3203

c-blosc2: A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2

CVE-2024-3203 is fixed in c-blosc2 on 1 platform, first by DEBIAN-CVE-2024-3203, released April 2, 2024. It is not reported as exploited. Patch Radar priority: Urgent.

Urgent
CVSS
9.8
critical
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0136
71st percentile

A vulnerability, which was classified as critical, was found in c-blosc2 up to 2.13.2. Affected is the function ndlz8_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz8x8.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. VDB-259050 is the identifier assigned to this vulnerability.

Where it's fixed

ProductFixed inFixReleased
Linux
c-blosc2 · Debian 13.5 (trixie) 2.13.1+ds-3 DEBIAN-CVE-2024-3203 Apr 2, 2024
c-blosc2 · Debian 14 2.13.1+ds-3 DEBIAN-CVE-2024-3203 Apr 2, 2024

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.