golang-github-lucas-clemente-quic-go: quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go
CVE-2023-49295 is fixed in 2 products on 1 platform, first by DEBIAN-CVE-2023-49295, released January 10, 2024. It is not reported as exploited. Patch Radar priority: Routine.
quic-go is an implementation of the QUIC protocol (RFC 9000, RFC 9001, RFC 9002) in Go. An attacker can cause its peer to run out of memory sending a large number of PATH_CHALLENGE frames. The receiver is supposed to respond to each PATH_CHALLENGE frame with a PATH_RESPONSE frame. The attacker can prevent the receiver from sending out (the vast majority of) these PATH_RESPONSE frames by collapsing the peers congestion window (by selectively acknowledging received packets) and by manipulating the peer's RTT estimate. This vulnerability has been patched in versions 0.37.7, 0.38.2 and 0.39.4.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| dnscrypt-proxy · opensuse-leap 16.0 | 2.1.16-bp160.1.1 | OPENSUSE-RU-2026:21160-1 | Jun 25, 2026 |
| golang-github-lucas-clemente-quic-go · Debian 13.5 (trixie) | 0.38.2-1 | DEBIAN-CVE-2023-49295 | Jan 10, 2024 |
| golang-github-lucas-clemente-quic-go · Debian 14 | 0.38.2-1 | DEBIAN-CVE-2023-49295 | Jan 10, 2024 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.