CVE-2023-43643

libowasp-antisamy-java: AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources

CVE-2023-43643 is fixed in libowasp-antisamy-java on 1 platform, first by DEBIAN-CVE-2023-43643, released October 9, 2023. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
6.1
medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0054
45th percentile

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.

Where it's fixed

ProductFixed inFixReleased
Linux
libowasp-antisamy-java · Debian 13.5 (trixie) 1.7.4-1 DEBIAN-CVE-2023-43643 Oct 9, 2023
libowasp-antisamy-java · Debian 14 1.7.4-1 DEBIAN-CVE-2023-43643 Oct 9, 2023

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.