opennds: An issue was discovered in the captive portal in OpenNDS before version 10.1.3
CVE-2023-41101 is fixed in opennds on 1 platform by DEBIAN-CVE-2023-41101 (version 10.2.0+dfsg-1), released November 17, 2023. It is not reported as exploited. Patch Radar priority: Urgent.
An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| opennds · Debian 13.5 (trixie) | 10.2.0+dfsg-1 | DEBIAN-CVE-2023-41101 | Nov 17, 2023 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.