CVE-2023-40032

vips: libvips is a demand-driven, horizontally threaded image processing library

CVE-2023-40032 is fixed in 4 products on 1 platform, first by gir1.2-vips-8.0 8.12.1-1ubuntu0.1~esm1, released September 11, 2023. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
5.5
medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0025
16th percentile

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

Where it's fixed

ProductFixed inFixReleased
Linux
gir1.2-vips-8.0 · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm1 gir1.2-vips-8.0 8.12.1-1ubuntu0.1~esm1 Sep 11, 2023
libvips-tools · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm1 libvips-tools 8.12.1-1ubuntu0.1~esm1 Sep 11, 2023
libvips42 · Ubuntu 22.04.1 LTS (jammy) 8.12.1-1ubuntu0.1~esm1 libvips42 8.12.1-1ubuntu0.1~esm1 Sep 11, 2023
vips · Debian 12.15 (bookworm) 8.14.1-3+deb12u1 DEBIAN-CVE-2023-40032 Sep 11, 2023
vips · Debian 13.5 (trixie) 8.14.4-1 DEBIAN-CVE-2023-40032 Sep 11, 2023
vips · Debian 14 8.14.4-1 DEBIAN-CVE-2023-40032 Sep 11, 2023

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.