CVE-2023-30631

trafficserver: Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.  The configuration optio...

CVE-2023-30631 is fixed in trafficserver on 1 platform by DEBIAN-CVE-2023-30631 (version 9.2.0+ds-2+deb12u1), released June 14, 2023. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.5
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0201
80th percentile

Improper Input Validation vulnerability in Apache Software Foundation Apache Traffic Server.  The configuration option proxy.config.http.push_method_enabled didn't function.  However, by default the PUSH method is blocked in the ip_allow configuration file.This issue affects Apache Traffic Server: from 8.0.0 through 9.2.0. 8.x users should upgrade to 8.1.7 or later versions 9.x users should upgrade to 9.2.1 or later versions

Where it's fixed

ProductFixed inFixReleased
Linux
trafficserver · Debian 12.15 (bookworm) 9.2.0+ds-2+deb12u1 DEBIAN-CVE-2023-30631 Jun 14, 2023

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.