CVE-2023-2905

swupdate: Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header...

CVE-2023-2905 is fixed in swupdate on 1 platform, first by DEBIAN-CVE-2023-2905, released August 9, 2023. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
8.8
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0101
63rd percentile

Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.

Where it's fixed

ProductFixed inFixReleased
Linux
swupdate · Debian 13.5 (trixie) 2024.12+dfsg-1 DEBIAN-CVE-2023-2905 Aug 9, 2023
swupdate · Debian 14 2024.12+dfsg-1 DEBIAN-CVE-2023-2905 Aug 9, 2023

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.