libowasp-antisamy-java: Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes...
CVE-2022-28366 is fixed in libowasp-antisamy-java on 1 platform, first by DEBIAN-CVE-2022-28366, released April 21, 2022. It is not reported as exploited. Patch Radar priority: High.
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| libowasp-antisamy-java · Debian 13.5 (trixie) | 1.7.4-1 | DEBIAN-CVE-2022-28366 | Apr 21, 2022 |
| libowasp-antisamy-java · Debian 14 | 1.7.4-1 | DEBIAN-CVE-2022-28366 | Apr 21, 2022 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.