CVE-2022-24775

php-guzzlehttp-psr7: guzzlehttp/psr7 is a PSR-7 HTTP message library

CVE-2022-24775 is fixed in php-guzzlehttp-psr7 on 1 platform, first by DEBIAN-CVE-2022-24775, released March 21, 2022. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
7.5
high
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0248
84th percentile

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Where it's fixed

ProductFixed inFixReleased
Linux
php-guzzlehttp-psr7 · Debian 12.15 (bookworm) 1.8.5-1 DEBIAN-CVE-2022-24775 Mar 21, 2022
php-guzzlehttp-psr7 · Debian 13.5 (trixie) 1.8.5-1 DEBIAN-CVE-2022-24775 Mar 21, 2022
php-guzzlehttp-psr7 · Debian 14 1.8.5-1 DEBIAN-CVE-2022-24775 Mar 21, 2022
php-guzzlehttp-psr7 · Ubuntu 20.04 LTS (focal) 1.4.2-0.1+deb10u2build0.20.04.1 php-guzzlehttp-psr7 1.4.2-0.1+deb10u2build0.20.04.1 Apr 17, 2023
php-guzzlehttp-psr7 · Ubuntu 22.04.1 LTS (jammy) 1.8.3-1ubuntu0.1~esm1 php-guzzlehttp-psr7 1.8.3-1ubuntu0.1~esm1 Apr 17, 2023

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.