node-bl: A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an att...
CVE-2020-8244 is fixed in node-bl on 1 platform by node-bl 1.1.2-1ubuntu1.1 (version 1.1.2-1ubuntu1.1), released August 30, 2020. It is not reported as exploited. Patch Radar priority: Routine.
A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| node-bl · Ubuntu 18.04.6 LTS (bionic) | 1.1.2-1ubuntu1.1 | node-bl 1.1.2-1ubuntu1.1 | Aug 30, 2020 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.