CVE-2020-7729

grunt: The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function lo...

CVE-2020-7729 is fixed in grunt on 1 platform, first by grunt 1.0.1-8ubuntu0.1, released September 3, 2020. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0230
83rd percentile

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

Where it's fixed

ProductFixed inFixReleased
Linux
grunt · Ubuntu 18.04.6 LTS (bionic) 1.0.1-8ubuntu0.1 grunt 1.0.1-8ubuntu0.1 Sep 3, 2020
grunt · Ubuntu 20.04 LTS (focal) 1.0.4-2ubuntu0.1~esm1 grunt 1.0.4-2ubuntu0.1~esm1 May 10, 2022

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.