libxstream-java: XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to...
CVE-2020-26217 is fixed in libxstream-java on 1 platform, first by libxstream-java 1.4.11.1-1~18.04.1, released December 15, 2020. It is not reported as exploited. Patch Radar priority: Routine.
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| libxstream-java · Ubuntu 18.04.6 LTS (bionic) | 1.4.11.1-1~18.04.1 | libxstream-java 1.4.11.1-1~18.04.1 | Dec 15, 2020 |
| libxstream-java · Ubuntu 20.04 LTS (focal) | 1.4.11.1-1ubuntu0.1 | libxstream-java 1.4.11.1-1ubuntu0.1 | Dec 15, 2020 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.