libzmq5: In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability
CVE-2020-15166 is fixed in libzmq5 on 1 platform, first by libzmq5 4.2.5-1ubuntu0.2+esm1, released September 11, 2020. It is not reported as exploited. Patch Radar priority: Routine.
In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability. Users with TCP transport public endpoints, even with CURVE/ZAP enabled, are impacted. If a raw TCP socket is opened and connected to an endpoint that is fully configured with CURVE/ZAP, legitimate clients will not be able to exchange any message. Handshakes complete successfully, and messages are delivered to the library, but the server application never receives them. This is patched in version 4.3.3.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| libzmq5 · Ubuntu 18.04.6 LTS (bionic) | 4.2.5-1ubuntu0.2+esm1 | libzmq5 4.2.5-1ubuntu0.2+esm1 | Sep 11, 2020 |
| libzmq5 · Ubuntu 20.04 LTS (focal) | 4.3.2-2ubuntu1.20.04.1~esm1 | libzmq5 4.3.2-2ubuntu1.20.04.1~esm1 | Sep 11, 2020 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.