ansible: A flaw was found in the use of insufficiently random values in Ansible
CVE-2020-10729 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1+esm5 (version 2.5.1+dfsg-1ubuntu0.1+esm5), released May 27, 2021. It is not reported as exploited. Patch Radar priority: Routine.
A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| ansible · Ubuntu 18.04.6 LTS (bionic) | 2.5.1+dfsg-1ubuntu0.1+esm5 | ansible 2.5.1+dfsg-1ubuntu0.1+esm5 | May 27, 2021 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.