CVE-2019-3828

ansible: Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying an...

CVE-2019-3828 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1 (version 2.5.1+dfsg-1ubuntu0.1), released July 30, 2019. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0052
44th percentile

Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outside of the specified destination in the local ansible controller host, by not restricting an absolute path.

Where it's fixed

ProductFixed inFixReleased
Linux
ansible · Ubuntu 18.04.6 LTS (bionic) 2.5.1+dfsg-1ubuntu0.1 ansible 2.5.1+dfsg-1ubuntu0.1 Jul 30, 2019

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.