ansible: In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, wer...
CVE-2019-14846 is fixed in ansible on 1 platform by ansible 2.5.1+dfsg-1ubuntu0.1+esm5 (version 2.5.1+dfsg-1ubuntu0.1+esm5), released May 27, 2021. It is not reported as exploited. Patch Radar priority: Routine.
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| ansible · Ubuntu 18.04.6 LTS (bionic) | 2.5.1+dfsg-1ubuntu0.1+esm5 | ansible 2.5.1+dfsg-1ubuntu0.1+esm5 | May 27, 2021 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.