CVE-2019-13917

exim4: Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use...

CVE-2019-13917 is fixed in 6 products on 1 platform, first by exim4 4.90.1-1ubuntu1.3, released July 25, 2019. It is not reported as exploited. Patch Radar priority: Routine.

Routine
CVSS
n/a
Medium
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.0862
95th percentile

Exim 4.85 through 4.92 (fixed in 4.92.1) allows remote code execution as root in some unusual configurations that use the ${sort } expansion for items that can be controlled by an attacker (e.g., $local_part or $domain).

Where it's fixed

ProductFixed inFixReleased
Linux
exim4 · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 exim4 4.90.1-1ubuntu1.3 Jul 25, 2019
exim4-base · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 exim4-base 4.90.1-1ubuntu1.3 Jul 25, 2019
exim4-config · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 exim4-config 4.90.1-1ubuntu1.3 Jul 25, 2019
exim4-daemon-heavy · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 exim4-daemon-heavy 4.90.1-1ubuntu1.3 Jul 25, 2019
exim4-daemon-light · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 exim4-daemon-light 4.90.1-1ubuntu1.3 Jul 25, 2019
eximon4 · Ubuntu 18.04.6 LTS (bionic) 4.90.1-1ubuntu1.3 eximon4 4.90.1-1ubuntu1.3 Jul 25, 2019

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.