CVE-2019-13132

libzmq5: In ZeroMQ libzmq before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.3.2, a remote, unauthenticated client connectin...

CVE-2019-13132 is fixed in libzmq5 on 1 platform by libzmq5 4.2.5-1ubuntu0.2 (version 4.2.5-1ubuntu0.2), released July 8, 2019. It is not reported as exploited. Patch Radar priority: High.

High
CVSS
n/a
High
Exploitation
None reported
No vendor assessment
CISA KEV
Not listed
Not in the Known Exploited Vulnerabilities catalog
EPSS
0.4246
98th percentile

In ZeroMQ libzmq before 4.0.9, 4.1.x before 4.1.7, and 4.2.x before 4.3.2, a remote, unauthenticated client connecting to a libzmq application, running with a socket listening with CURVE encryption/authentication enabled, may cause a stack overflow and overwrite the stack with arbitrary data, due to a buffer overflow in the library. Users running public servers with the above configuration are highly encouraged to upgrade as soon as possible, as there are no known mitigations.

Where it's fixed

ProductFixed inFixReleased
Linux
libzmq5 · Ubuntu 18.04.6 LTS (bionic) 4.2.5-1ubuntu0.2 libzmq5 4.2.5-1ubuntu0.2 Jul 8, 2019

Patch Radar data is free to use with attribution. Terms and how to credit it.

Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.