prosody: prosody before versions 0.10.2, 0.9.14 is vulnerable to an Authentication Bypass
CVE-2018-10847 is fixed in prosody on 1 platform by prosody 0.10.0-1ubuntu0.1~esm1 (version 0.10.0-1ubuntu0.1~esm1), released July 30, 2018. It is not reported as exploited. Patch Radar priority: Routine.
prosody before versions 0.10.2, 0.9.14 is vulnerable to an Authentication Bypass. Prosody did not verify that the virtual host associated with a user session remained the same across stream restarts. A user may authenticate to XMPP host A and migrate their authenticated session to XMPP host B of the same Prosody instance.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| prosody · Ubuntu 18.04.6 LTS (bionic) | 0.10.0-1ubuntu0.1~esm1 | prosody 0.10.0-1ubuntu0.1~esm1 | Jul 30, 2018 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.