python3-flask: The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask t...
CVE-2018-1000656 is fixed in 2 products on 1 platform, first by python-flask 0.12.2-3ubuntu0.1, released August 20, 2018. It is not reported as exploited. Patch Radar priority: Routine.
The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| python-flask · Ubuntu 18.04.6 LTS (bionic) | 0.12.2-3ubuntu0.1 | python-flask 0.12.2-3ubuntu0.1 | Aug 20, 2018 |
| python3-flask · Ubuntu 18.04.6 LTS (bionic) | 0.12.2-3ubuntu0.1 | python3-flask 0.12.2-3ubuntu0.1 | Aug 20, 2018 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.