curl: curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of...
CVE-2018-1000301 is fixed in 4 products on 1 platform, first by curl 7.58.0-2ubuntu3.1, released May 15, 2018. It is not reported as exploited. Patch Radar priority: Routine.
curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.
Where it's fixed
| Product | Fixed in | Fix | Released |
|---|---|---|---|
| Linux | |||
| curl · Ubuntu 18.04.6 LTS (bionic) | 7.58.0-2ubuntu3.1 | curl 7.58.0-2ubuntu3.1 | May 15, 2018 |
| libcurl3-gnutls · Ubuntu 18.04.6 LTS (bionic) | 7.58.0-2ubuntu3.1 | libcurl3-gnutls 7.58.0-2ubuntu3.1 | May 15, 2018 |
| libcurl3-nss · Ubuntu 18.04.6 LTS (bionic) | 7.58.0-2ubuntu3.1 | libcurl3-nss 7.58.0-2ubuntu3.1 | May 15, 2018 |
| libcurl4 · Ubuntu 18.04.6 LTS (bionic) | 7.58.0-2ubuntu3.1 | libcurl4 7.58.0-2ubuntu3.1 | May 15, 2018 |
Patch Radar data is free to use with attribution. Terms and how to credit it.
Product names, logos and trademarks shown on Patch Radar belong to their respective owners. They are used only to identify the software each security fix applies to and to help readers find their platform. Their use does not imply any affiliation with, or endorsement by, those owners, and Patchblox is not affiliated with any of them.